SQLite Forum

v3.36.0 fails to compile under Ubuntu

v3.36.0 fails to compile under Ubuntu

(1) By anonymous on 2021-09-08 23:49:46 [source]

I tried to compile (tag) release (v3.36.0) today under Ubuntu and got the following error:

sqlite3.c:38013:12: warning: ‘unixFcntlExternalReader’ used but never defined
 static int unixFcntlExternalReader(unixFile*, int*);

I've been using the exact same command to compile all (recent) previous versions without issues:


Any ideas what change since 3.35.5 broke it, or how to fix?

(2) By Richard Hipp (drh) on 2021-09-09 00:56:20 in reply to 1 [link] [source]

Try leaving out the -DSQLITE_OMIT_WAL.

(4) By anonymous on 2021-09-09 18:54:56 in reply to 2 [link] [source]

That worked, thanks.

(3) By David Jones (vman59) on 2021-09-09 01:17:07 in reply to 1 [link] [source]

It looks like it is related to WAL file processing and your -DSQLITE_OMIT_WAL disables the creation of the function but not the call to it in unixFileControl().

(5) By Daniel Sahlberg (dsahlberg) on 2021-11-02 08:48:18 in reply to 3 [link] [source]

The same error was reported by a user building Subversion using the amalgamation ZIP file.


Is there an issue tracker or is it enough to bring it up on the forum?

(6) By Stephan Beal (stephan) on 2021-11-02 13:49:08 in reply to 5 [link] [source]

Is there an issue tracker or is it enough to bring it up on the forum?

sqlite's ticket system is not open for anonymous submissions - the forum is the correct place to report problems.

The workaround for this issue, since verified by the OP, is given further up in this thread:

Try leaving out the -DSQLITE_OMIT_WAL.

(7) By Larry Brasfield (larrybr) on 2021-11-02 17:28:53 in reply to 5 [link] [source]

Dan Kennedy has fixed this build problem with this checkin.