SQLite Forum

create sqlite3_analyzer from trunk
Hi Richard, is the Makefile supposed to create the sqlite3_analyzer executable automatically? If so I suspect it's a TCL problem.

I installed TCL using 'sudo apt-get install tcl8.6-dev'.

I've got the trunk files in directory ~/sqlite. I run the following script from that directory

echo "updating trunk ..."
exec > /dev/null
fossil update trunk

It does create sqlite3.c, sqlite3.o & sqlite3 but no sqldiff or sqlite3_analyzer. I get the following messages

updating trunk ...
configure: WARNING: Can't find Tcl configuration definitions
configure: WARNING: *** Without Tcl the regression tests cannot be executed ***
configure: WARNING: *** Consider using --with-tcl=... to define location of Tcl ***
ar: `u' modifier ignored since `D' is the default (see `U')

If I run 'make sqlite3_analyzer' I get

sqlite3_analyzer.c:233072:11: fatal error: tcl.h: No such file or directory
233072 | # include "tcl.h"
       |           ^~~~~~~
compilation terminated.
make: *** [Makefile:1308: sqlite3_analyzer] Error 1

I have spent 2 hours trying to find what I should add to the PATH so tcl can be accessed but I'm none the wiser.