SQLite Forum

cannot create tables in sqlitestudio than other apps can see
Sorry for causing confusion.

The problem is I get the message "unable to open database file" when I run a Delphi program on my Win10 laptop.

This is a message that could mean there is no sqlite database file by the name specified in the program, or because the file is in a read-only folder, or windows 10 is blocking it via Defender or the firewall, (but the file really is there in the folder the program expects it to in, the read-only attribute is not set for the folder as specified, which is why I put it on a usb thumb drive, as all older folders have the read-only attribute set even though the are not read only), or the database file is corrupted, though I can read the same file on a win 7 computer, and have tried several program to create the database file, and none of the files can be opened on Windows 10).

I have tried to ensure the correct dll for sqlite is on the path and in the folder with the database file and where the .exe file is.

As far as I know, I have eliminated every known possibility that could cause the "unable to open" message, including reinstalling Window 10 and Delphi 10.3, but obviously I overlooked something.