SQLite Forum

How to clone this forum?
Login

How to clone this forum?

(1) By František Kučera (franta) on 2020-04-20 09:48:03 [link] [source]

I tried

fossil clone https://sqlite.org/forum/ forum

and got the forum file, but it does not seem to contain the forum posts – when I start the UI:

fossil ui forum

the links like http://localhost:8080/forumnew or http://localhost:8080/forummain are not working (Page not found) and Recent / Timeline shows zero items.

I used to have an offline archive of the mailing list on my computer (in my mailbox). Is this kind of experience possible with this forum?

Franta

(2) By Warren Young (wyoung) on 2020-04-20 10:06:57 [link] [source] in reply to 1

links like http://localhost:8080/forumnew or http://localhost:8080/forummain are not working

Works here.

The forummain feature only goes back to 2020-03-12, so unless you're running a pre-release build of Fossil from the current trunk, that name won't work. In prior versions, only /forum worked. (I guess drh just didn't like /forum/forum and wanted the second level to be distinct from the first.)

As for forumnew, that should always work, going back to very early in the Forum feature's lifetime, which was initially released as part of Fossil 2.7.

Therefore, I would guess that this and your prior problem come from using an older version of Fossil, such as 2.5, which Ubuntu was still shipping, last time I checked.

Recent / Timeline shows zero items.

The default view shows check-ins only. Either pull down the right-most pull-down in the submenu bar and select Forum or give this command:

  $ fossil timeline -R forum

(3) By František Kučera (franta) on 2020-04-20 10:13:40 [source] in reply to 2

Yes, I have Fossil 2.5. I will try newer version. Thanks!