SQLite Forum

Serious Sqlite command line Problems after Windows 10 update
After the current WINDOWS 10 update to one of our customers Laptops, the SQLITE command processor began to fail in strange and sometimes intermittent ways. 
 A file of valid SQL commands (that has always worked before the update) redirected as inputs to  SQLITE was not processed and just the prompt for commands displayed. (The SQKUTE prompt was in fact strangely displayed in a new command window to the original) and if you typed a valid command like .HELP it was rejected.
Also, if you invoked SQLITE by typing the command, at the command prompt all valid commands you typed were rejected.

(On our user's machine, the initial attempt to carry out the windows update had failed - possibly due to Low disk space - but was later installed successfully - he first attempted to uninstall the update this failed and he contacted Microsoft and they advised him to download a new version of windows which he did - but the sqlite problem was not completely solved - it was now possible to type commands and get them recognized but not redirect inputs from a file to sqlite - but we proved the windows redirect function does work with other command line applications  and it was only affecting SQLITE)

Unfortunately, immediately after my windows 10  laptop had the same windows update - which like the users first failed and then succeeded-  my laptop developed the same fault, but after carrying out 2 chkdsk's it started to work again, but on a reboot, failed again, but has now started to work again - which seems to defy common sense but is happening. 
I realise it is likely to be a windows fault somewhere,  but it only seems to be affecting SQLITE.
 So perhaps someone familiar with sqlite may have some idea what is  happening and why!