SQLite4
Check-in [8132a601e8]
Not logged in

Many hyperlinks are disabled.
Use anonymous login to enable hyperlinks.

Overview
Comment:Change the name of "storage.h" to "kv.h". Other minor edits to comments and typedefs.
Downloads: Tarball | ZIP archive | SQL archive
Timelines: family | ancestors | descendants | both | trunk
Files: files | file ages | folders
SHA1: 8132a601e86a5d97869856204fa28240fe4f7e53
User & Date: drh 2012-10-20 12:57:54
Context
2012-10-20
13:01
Change the "TK_" macro prefix in lsm_tree.c to "TKV_" in order to avoid name collisions with "TK_" macros generated by the parser. check-in: b81bc323b9 user: drh tags: trunk
12:57
Change the name of "storage.h" to "kv.h". Other minor edits to comments and typedefs. check-in: 8132a601e8 user: drh tags: trunk
2012-10-19
16:39
Remove obsolete content from sqliteInt.h. check-in: d618b9b106 user: drh tags: trunk
Changes
Unified Diffs Side-by-Side Diffs Patch

Changes to main.mk.

Name change from src/storage.h to src/kv.h.

Changes to src/kvlsm.c.

Changes to src/kvmem.c.

Changes to src/shell.c.

Changes to src/sqlite.h.in.

Changes to src/sqliteInt.h.

Changes to src/vdbe.c.

Changes to tool/mksqlite4c.tcl.