SQLite Forum

cannot create tables in sqlitestudio than other apps can see
Still no success.
I spent the data formatting the hard drive on my laptop, doing a "clean install" of windows, which took much longer than doing the "Reset" option, then I wrote a new Delphi program on my working win7 pc. I created a new .db sqlite adtabase file, and I added the folder and name of the .db file to a tedt.

When I click the go button, it first checks that file exists for the value in the tedit, then sets the connection params[1] to that value, then opens the connection and runs the query.

I then copied the exe file and the .db file to a usb drive and it runs fine on win 7. I put the usb drive in the laptop of went there to run it. I had the change the drive letter, as the usb drive on the laptop is  "D", not "E" like the win7 machine.

I right clicked on the file to get the properties, and as |I hoped, it did not say read only like it does on all the other files I have on that machine.

I ran it with great hopes... it said the file was there, and it ended with the same error message "unable to open database file".

I ran it in SAFE mode to turn off the antivirus and firewall in case they were blocking it. I am completely out of ideas.

Is there any person out there that can run a Delphi 7 on a win7 computer, then see if it runs on win 10? I realize most people probably don't have a win7 and a win10 pc.