SQLite Forum

cannot create tables in sqlitestudio than other apps can see
I have had what looked like some "progress" which raises more questions
1. I created a new Delphi program with a button whose onclick says "tsqlconnection1.open";
the connection parameters set by me in the IDE are:


I made several attempts with the filename beginning with "localhost" which did not help.

with the db file in the root directory, with no "\"
It would fail with "unable to open database", but I went into data explorer, selected sqliteconnection
and right clicked and tried to "modify".
I entered steve-laptop as the host name, and "C:\mynewdata" with the backslash, after nothing else worked.
When I click test connection, it succeeds!

I dropped a tsqlquery on the form, wrote a simple select statement, and set the connection to sqlconnection1.
When I run it I get external exception C06D007F.

In the IDE under data explorer, under sqliteconnection, there are no entries under table, views,
 or procedures, even though the properties of sqlconnection1.connected is TRUE.

I right clicked on "tables" in data explorer and it gave me an option for a new table. I selected that, added a couple fields, 
but when I went to save it, the error message was "attempt to write a readonly database".

I sent back to the connection params and entered a table name that was not in the root directory, making it necessary
to have backslashes. Clicking  test Connection still works, and the new table still does not appear under "tables".
When I run the program I still get the external exception error.