SQLite Forum

cannot create tables in sqlitestudio than other apps can see
> 1. I created a new Delphi program with a button whose onclick says "tsqlconnection1.open";
the connection parameters set by me in the IDE are:<code>

When you use "C:filename" as a file path, what it means to the OS is "In the process current directory as kept for the 'C:' drive, find or create and use a file whose plain name is 'filename'. In other words, its meaning depends on something unlikely to be well controlled or understood easily by anybody reading the code.

> I made several attempts with the filename beginning with "localhost" which did not help.

If that made any difference, it would mean you are using either a driver attempting to involve a network layer or one created by demented folk.

> with the db file in the root directory, with no "\\"
It would fail with "unable to open database", but I went into data explorer, selected sqliteconnection and right clicked and tried to "modify". I entered steve-laptop as the host name, and "C:\\mynewdata" with the backslash, after nothing else worked. When I click test connection, it succeeds!

That is because, with that leading backslash (after the drive specifier), you were specifying an absolute path, just as I, Simon and others have advised. (See above regarding "process current directory".

And please, in future posts, even if you cannot learn all of the markdown rules, double your backslash characters to produce something that renders as \\. Without doing that, your single backslashes render as nothing, leading to needless confusion and/or effort to look at your post in raw form.