SQLite Forum

SQL not responding when opened

SQL not responding when opened

(1) By anonymous on 2020-11-04 05:43:20 [link]

I had no problem with SQL working up until a couple days ago. It is now always saying “Not Responding” in the top bar and I can’t seem to get it to work. I have tried redownloading the files and program multiple times with no success.

(2) By Ryan Smith (cuz) on 2020-11-04 12:07:30 in reply to 1 [link]

What is not responding?

The CLI? Some Window?  

Which files did you download?  Did it compile correctly?

How do you open the file?  which Program?  Which version of it?  Which OS?

Based on nothing but a weak "hunch", I would say you probably have a very large DB file, tried to do a long-running transaction, decided to kill it at some point, and now the roll-back journal is telling the engine to roll it back (automatic upon opening the connection) and trying an equally long-running process of rolling back the changes every time you try to open it (which cannot really take very long with most journal modes).

But without detail, it's extremely hard to say.

(3) By Gunter Hick (gunter_hick) on 2020-11-04 12:08:30 in reply to 1

A tad more detail may be helpful. Telling us what operating system and what the "top bar" is would be a start.